summaryrefslogtreecommitdiff
path: root/dev-perl/Test-TCP/Test-TCP-2.190.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-TCP/Test-TCP-2.190.0-r1.ebuild')
-rw-r--r--dev-perl/Test-TCP/Test-TCP-2.190.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Test-TCP/Test-TCP-2.190.0-r1.ebuild b/dev-perl/Test-TCP/Test-TCP-2.190.0-r1.ebuild
new file mode 100644
index 000000000000..b258a071cfe4
--- /dev/null
+++ b/dev-perl/Test-TCP/Test-TCP-2.190.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TOKUHIROM
+DIST_VERSION=2.19
+inherit perl-module
+
+DESCRIPTION="Testing TCP program"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-IO
+ virtual/perl-IO-Socket-IP
+ >=dev-perl/Test-SharedFork-0.290.0
+ virtual/perl-Test-Simple
+ >=virtual/perl-IO-1.230.0
+ virtual/perl-Time-HiRes
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ >=virtual/perl-Test-Simple-0.980.0
+ virtual/perl-File-Temp
+ virtual/perl-Socket
+ )
+"
+PATCHES=( "${FILESDIR}/${PN}-2.19-no-dot-inc.patch" )