summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Object/Test-Object-0.70.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-Object/Test-Object-0.70.0-r1.ebuild')
-rw-r--r--dev-perl/Test-Object/Test-Object-0.70.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Test-Object/Test-Object-0.70.0-r1.ebuild b/dev-perl/Test-Object/Test-Object-0.70.0-r1.ebuild
new file mode 100644
index 000000000000..00065b024407
--- /dev/null
+++ b/dev-perl/Test-Object/Test-Object-0.70.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ADAMK
+DIST_VERSION=0.07
+inherit perl-module
+
+DESCRIPTION="Thoroughly testing objects via registered handlers"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND="virtual/perl-File-Spec
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test-Simple"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}