summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Compile/Test-Compile-2.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Test-Compile/Test-Compile-2.4.1.ebuild')
-rw-r--r--dev-perl/Test-Compile/Test-Compile-2.4.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Test-Compile/Test-Compile-2.4.1.ebuild b/dev-perl/Test-Compile/Test-Compile-2.4.1.ebuild
new file mode 100644
index 000000000000..92cdc20fcc54
--- /dev/null
+++ b/dev-perl/Test-Compile/Test-Compile-2.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=EGILES
+DIST_VERSION=v2.4.1
+inherit perl-module
+
+DESCRIPTION="Check whether Perl files compile correctly"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? (
+ dev-perl/Devel-CheckOS
+ )
+ >=virtual/perl-Exporter-5.680.0
+ dev-perl/UNIVERSAL-require
+ >=virtual/perl-parent-0.225.0
+ virtual/perl-version
+"
+DEPEND="dev-perl/Module-Build"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warnings
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/999-has-version.t
+ t/999-perlcritic.t
+ t/999-pod-coverage.t
+ t/999-pod.t
+ t/999-portability.t
+ t/999-synopsis.t
+ t/999-version.t
+)