summaryrefslogtreecommitdiff
path: root/dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild')
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild b/dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild
new file mode 100644
index 000000000000..16cad8c07a60
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Packages which get releases together:
+# app-emacs/nxml-libvirt-schemas
+# dev-python/libvirt-python
+# dev-perl/Sys-Virt
+# app-emulation/libvirt
+# Please bump them together!
+
+DIST_AUTHOR=DANBERR
+DIST_VERSION=v${PV}
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-emulation/libvirt-${PV}
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ dev-perl/Module-Build
+ virtual/pkgconfig
+ test? (
+ dev-perl/CPAN-Changes
+ dev-perl/Test-More-UTF8
+ dev-perl/Test-Pod-Coverage
+ dev-perl/XML-XPath
+ virtual/perl-Test-Simple
+ virtual/perl-Time-HiRes
+ )"
+DEPEND="
+ >=app-emulation/libvirt-${PV}
+"