summaryrefslogtreecommitdiff
path: root/dev-perl/SVG-Graph
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/SVG-Graph')
-rw-r--r--dev-perl/SVG-Graph/Manifest5
-rw-r--r--dev-perl/SVG-Graph/SVG-Graph-0.20.0-r1.ebuild24
-rw-r--r--dev-perl/SVG-Graph/metadata.xml31
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-perl/SVG-Graph/Manifest b/dev-perl/SVG-Graph/Manifest
new file mode 100644
index 000000000000..2fb6e5342843
--- /dev/null
+++ b/dev-perl/SVG-Graph/Manifest
@@ -0,0 +1,5 @@
+DIST SVG-Graph-0.02.tar.gz 85270 SHA256 0de0dfd6c2c6a5fa952e9cc5f56077851fcaea338e1d13915458b351b37061bc SHA512 7c98d290bce22afb853b6f2489cf9d8818c1d00974aaeff7475904187cb5444d732b8d551b6bf829921c890ced8e0ff11b75cd9a8feca7bbbcf5b41bf0476117 WHIRLPOOL e0d3502437567d1c85b8309887a7b7d52aabc179e7fef05dfb9f56f8e79325c295dab167d3c388a3590a92f92dcab2d4fbc4a6fa27a29ae6d8e8f26037e55433
+EBUILD SVG-Graph-0.20.0-r1.ebuild 491 SHA256 fc29be1c67d4dabf419cde0dab3a99f1eeaeaab6d425526d008a236a0ba4794b SHA512 d7f507f082625156286d8b1d10fef66f0f1c5a5858f0ddfd1dd6f89c0ed1205a4676a9622c47d641f2fdbc079ef47e8a28fd7e7d9cb4225a4a9a824af6123e2c WHIRLPOOL e1da11be689e6966180d85fc12de4487f6c4eaf14933b47d285b75abedb20c743b54be90b3b844a67533f16a2eea72a81a59e7173f9e66903e352867d644c827
+MISC ChangeLog 2441 SHA256 ef429ee3ea558819fb415e6e0d700fd47790de2df7d106c41c616653a3100116 SHA512 8b150797aea6ff4d3cfbcb23eef714f09d94e1269268a3fc53e24bdda9c825227052267b4cc2bd13a7d0271bb90e412ecb4767fa5d5d3c111c23ea9d1b6960af WHIRLPOOL ee51f34b221245592f26d000cdf123f873fa26393fa67e80c8c9aa7ab44f81223ec6870c9f873eab64576bfc26372b4a26ccfe6f2835f38b0e7d0b9c49a143eb
+MISC ChangeLog-2015 1439 SHA256 ca0944390d1df15b5f841e30879066178ac017d5d97927f82d64c38eaef66b7c SHA512 05578a9145d4b7c9f58766ead9696946e326c5e288b12b482c5625847f1d5f8e5c5761225d4c49ee8fcd65d7703bee154f07d6f20afac930f40985975cbf7df0 WHIRLPOOL 249cbf7dc9f5b64339b7c1a76aa88431461f8908ed3be56bc3033e4f1583ae15f9156d64736110605eaacffc846aa83596447f64897f6c98d9546a1ebf6c2db3
+MISC metadata.xml 1704 SHA256 d7ad0bc0b383a862d9ab965b4a9c71b3935abaaf930c13442ff13f9f20d049d6 SHA512 61697f444c736f0be457273926b1984ca4ea244a34233e5ab6cb693690f8e55c60c4395bf082a526f74d896887721ad5c786c061da1129c77a7758ff6398f811 WHIRLPOOL 8b8fe7f207d632a2e77bae9a5328f242711987e1fee008a8e862f4b5605991004ef010ac65f183844c3a1fb8917b0aa9e2e89aef1ceae16f6ab9bf495729f6a2
diff --git a/dev-perl/SVG-Graph/SVG-Graph-0.20.0-r1.ebuild b/dev-perl/SVG-Graph/SVG-Graph-0.20.0-r1.ebuild
new file mode 100644
index 000000000000..28ee2a0fc979
--- /dev/null
+++ b/dev-perl/SVG-Graph/SVG-Graph-0.20.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=ALLENDAY
+MODULE_VERSION=0.02
+inherit perl-module
+
+DESCRIPTION="Visualize your data in Scalable Vector Graphics (SVG) format"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-perl/Math-Derivative
+ dev-perl/Math-Spline
+ >=dev-perl/Statistics-Descriptive-2.6
+ dev-perl/SVG
+ >=dev-perl/Tree-DAG_Node-1.04"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/SVG-Graph/metadata.xml b/dev-perl/SVG-Graph/metadata.xml
new file mode 100644
index 000000000000..121eead2af9a
--- /dev/null
+++ b/dev-perl/SVG-Graph/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">SVG-Graph</remote-id>
+ <remote-id type="cpan-module">SVG::Graph</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Data</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Data::Datum</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Data::Node</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Data::Tree</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::File</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Frame</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Glyph</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Glyph::axis</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Glyph::bar</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Glyph::barflex</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Glyph::bezier</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Glyph::bubble</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Glyph::heatmap</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Glyph::line</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Glyph::pictogram</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Glyph::scatter</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Glyph::tree</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Glyph::wedge</remote-id>
+ <remote-id type="cpan-module">SVG::Graph::Group</remote-id>
+ </upstream>
+</pkgmetadata>