summaryrefslogtreecommitdiff
path: root/dev-perl/PDL-Graphics-Gnuplot/PDL-Graphics-Gnuplot-2.25.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/PDL-Graphics-Gnuplot/PDL-Graphics-Gnuplot-2.25.0.ebuild')
-rw-r--r--dev-perl/PDL-Graphics-Gnuplot/PDL-Graphics-Gnuplot-2.25.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/PDL-Graphics-Gnuplot/PDL-Graphics-Gnuplot-2.25.0.ebuild b/dev-perl/PDL-Graphics-Gnuplot/PDL-Graphics-Gnuplot-2.25.0.ebuild
new file mode 100644
index 000000000000..cd6598fda14e
--- /dev/null
+++ b/dev-perl/PDL-Graphics-Gnuplot/PDL-Graphics-Gnuplot-2.25.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_VERSION=2.025
+DIST_AUTHOR=ETJ
+inherit perl-module
+
+DESCRIPTION="Gnuplot-based plotting for PDL"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-perl/Alien-Gnuplot-1.31.0
+ >=virtual/perl-File-Temp-0.190.0
+ virtual/perl-IO
+ dev-perl/IPC-Run
+ virtual/perl-Scalar-List-Utils
+ dev-perl/PDL
+ dev-perl/PDL-Transform-Color
+ dev-perl/Safe-Isa
+ virtual/perl-Storable
+ virtual/perl-Time-HiRes
+ sci-visualization/gnuplot
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ test? ( virtual/perl-Test-Simple )
+"