summaryrefslogtreecommitdiff
path: root/dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild')
-rw-r--r--dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild b/dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild
new file mode 100644
index 000000000000..f33ff808f67d
--- /dev/null
+++ b/dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SMUELLER
+DIST_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="Numbers with error propagation and scientific rounding"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.400.0
+ >=dev-perl/Params-Util-0.100.0
+ >=dev-perl/prefork-1.0.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ dev-perl/Test-LectroTest
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-${DIST_VERSION}-no-dot-inc.patch"
+)
+PERL_RM_FILES=(
+ "t/00podcover.t"
+ "t/00pod.t"
+)