summaryrefslogtreecommitdiff
path: root/dev-perl/Net-Google-SafeBrowsing-Blocklist/Net-Google-SafeBrowsing-Blocklist-1.40.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-Google-SafeBrowsing-Blocklist/Net-Google-SafeBrowsing-Blocklist-1.40.0-r3.ebuild')
-rw-r--r--dev-perl/Net-Google-SafeBrowsing-Blocklist/Net-Google-SafeBrowsing-Blocklist-1.40.0-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Net-Google-SafeBrowsing-Blocklist/Net-Google-SafeBrowsing-Blocklist-1.40.0-r3.ebuild b/dev-perl/Net-Google-SafeBrowsing-Blocklist/Net-Google-SafeBrowsing-Blocklist-1.40.0-r3.ebuild
new file mode 100644
index 000000000000..55be88c205a8
--- /dev/null
+++ b/dev-perl/Net-Google-SafeBrowsing-Blocklist/Net-Google-SafeBrowsing-Blocklist-1.40.0-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DANBORN
+DIST_VERSION=1.04
+inherit perl-module
+
+DESCRIPTION="Query a Google SafeBrowsing table"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="dev-perl/URI
+ >=virtual/perl-Math-BigInt-1.87
+ virtual/perl-DB_File
+ || (
+ virtual/perl-Math-BigInt-FastCalc
+ dev-perl/Math-BigInt-GMP
+ )
+"
+BDEPEND="${RDEPEND}
+ test? ( virtual/perl-Test-Simple )
+"
+
+PERL_RM_FILES=( "t/pod.t" )