summaryrefslogtreecommitdiff
path: root/dev-perl/MooseX-Getopt/MooseX-Getopt-0.710.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/MooseX-Getopt/MooseX-Getopt-0.710.0.ebuild')
-rw-r--r--dev-perl/MooseX-Getopt/MooseX-Getopt-0.710.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/MooseX-Getopt/MooseX-Getopt-0.710.0.ebuild b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.710.0.ebuild
new file mode 100644
index 000000000000..45e519cc0472
--- /dev/null
+++ b/dev-perl/MooseX-Getopt/MooseX-Getopt-0.710.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.71
+inherit perl-module
+
+DESCRIPTION="A Moose role for processing command line options"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Getopt-Long-2.370.0
+ >=dev-perl/Getopt-Long-Descriptive-0.88.0
+ >=dev-perl/Moose-0.560.0
+ >=dev-perl/MooseX-Role-Parameterized-1.10.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ dev-perl/namespace-autoclean
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Module-Runtime
+ virtual/perl-Module-Metadata
+ >=dev-perl/Path-Tiny-0.9.0
+ dev-perl/Test-Deep
+ >=dev-perl/Test-Fatal-0.3.0
+ virtual/perl-Test-Simple
+ dev-perl/Test-Requires
+ dev-perl/Test-Trap
+ >=dev-perl/Test-Warnings-0.9.0
+ virtual/perl-if
+ )
+"