summaryrefslogtreecommitdiff
path: root/dev-perl/Linux-Smaps/Linux-Smaps-0.140.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Linux-Smaps/Linux-Smaps-0.140.0.ebuild')
-rw-r--r--dev-perl/Linux-Smaps/Linux-Smaps-0.140.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-perl/Linux-Smaps/Linux-Smaps-0.140.0.ebuild b/dev-perl/Linux-Smaps/Linux-Smaps-0.140.0.ebuild
new file mode 100644
index 000000000000..088a9f9580a1
--- /dev/null
+++ b/dev-perl/Linux-Smaps/Linux-Smaps-0.140.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=AERUDER
+DIST_VERSION=0.14
+inherit perl-module linux-info
+
+DESCRIPTION="Perl interface to /proc/PID/smaps"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+"
+# This is only explict due to not seeing where
+# this variable gets used otherwise
+pkg_setup() {
+ CONFIG_CHECK="~MMU ~PROC_PAGE_MONITOR"
+ linux-info_pkg_setup
+}