summaryrefslogtreecommitdiff
path: root/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.140.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.140.0.ebuild')
-rw-r--r--dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.140.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.140.0.ebuild b/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.140.0.ebuild
new file mode 100644
index 000000000000..98958cbf74fa
--- /dev/null
+++ b/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.140.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=OALDERS
+DIST_VERSION=6.14
+inherit perl-module
+
+DESCRIPTION="Provide https support for LWP::UserAgent"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-perl/IO-Socket-SSL-1.970.0
+ >=dev-perl/libwww-perl-6.60.0
+ >=dev-perl/Net-HTTP-6
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Needs-0.2.10
+ virtual/perl-Test-Simple
+ dev-perl/Test-RequiresInternet
+ )
+"