summaryrefslogtreecommitdiff
path: root/dev-perl/Inline-Python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Inline-Python')
-rw-r--r--dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild38
-rw-r--r--dev-perl/Inline-Python/Manifest4
-rw-r--r--dev-perl/Inline-Python/files/Inline-Python-0.460.0-insanepython.patch20
-rw-r--r--dev-perl/Inline-Python/metadata.xml16
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild b/dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild
new file mode 100644
index 000000000000..6c071e0b894d
--- /dev/null
+++ b/dev-perl/Inline-Python/Inline-Python-0.560.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+# Feel free to add more targets after testing.
+
+DIST_AUTHOR=NINE
+DIST_VERSION=0.56
+inherit python-single-r1 perl-module
+
+DESCRIPTION="Easy implementation of Python extensions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ >=virtual/perl-Digest-MD5-2.500.0
+ >=dev-perl/Inline-0.460.0
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Proc-ProcessTable-0.530.0
+ virtual/perl-Test-Simple
+ dev-perl/Test-Deep
+ dev-perl/Test-Number-Delta
+ virtual/perl-Test
+ )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.460.0-insanepython.patch" )
diff --git a/dev-perl/Inline-Python/Manifest b/dev-perl/Inline-Python/Manifest
new file mode 100644
index 000000000000..664996d291f8
--- /dev/null
+++ b/dev-perl/Inline-Python/Manifest
@@ -0,0 +1,4 @@
+AUX Inline-Python-0.460.0-insanepython.patch 652 BLAKE2B 86734b5c86d7cb5affabb76f950ae6086581a0c5d1eda278cdd27047a49a57b3f2ce1a520e745b040179c945ba2f2cd7dc896e9a321702a05c7d935782196dd2 SHA512 f9fc8e8a287801f331ac92bdbd80f665648f9fee8dc43383fe563c6ca8e0aa4d01e06b09a25408b7908e5394cb4bf496e76441c6ee5dbf0fdb7c65dc4222bac1
+DIST Inline-Python-0.56.tar.gz 58224 BLAKE2B e422c46cfaaaf77a0a683ccf2818db62e5f2c726b9ede71f446bd2bb4fe66ba8ab8d99b30ce26168bf47cc23f06afc5b9839a403cd6b52781aa288a29cbedea3 SHA512 d5fffec8a377ec10c8b21ed9324e2de5a77d10304fc2a89196df89984e55869e3e4e0ef970f1aa4651068b8a6d834fa8eb18d70a052c646ddd98ef338f772e7d
+EBUILD Inline-Python-0.560.0.ebuild 804 BLAKE2B 5e7272c9bd9c31cb1ebbe0116430aa115f9bdbdb635d51ae882a0a75b7ef48fc5c161efe04079c68c336acc507f2a7482087aa2b1dbac6035d05569dc94531cc SHA512 7f0f19af0edca98a2879ca46a6284126110f5afd4f90c714acf29f6eb5f8629e00be7c4436f5acf61cb425a7b7f63e58eca8cb210440e13161c66a6621d7d563
+MISC metadata.xml 683 BLAKE2B 07299e0bfb8310004e589f3255875189c1ac2d8caebee63fb5229aa8acb83968215c8d80bf8ed89ecbb01d7672d6100795133b580536fc8490c00e89240d0812 SHA512 03b3a3f8697b678e054251de5bea03f3344c063b1ae93e6f674e30375062ac9d125af3c428d4f0869d333ded2831617af14b7908ba55c01638534970329ea17d
diff --git a/dev-perl/Inline-Python/files/Inline-Python-0.460.0-insanepython.patch b/dev-perl/Inline-Python/files/Inline-Python-0.460.0-insanepython.patch
new file mode 100644
index 000000000000..b713f170abe8
--- /dev/null
+++ b/dev-perl/Inline-Python/files/Inline-Python-0.460.0-insanepython.patch
@@ -0,0 +1,20 @@
+diff -ruN Inline-Python-0.46.orig/Makefile.PL Inline-Python-0.46/Makefile.PL
+--- Inline-Python-0.46.orig/Makefile.PL 2014-12-07 12:35:25.478476508 +0100
++++ Inline-Python-0.46/Makefile.PL 2014-12-11 00:37:37.580577317 +0100
+@@ -134,7 +134,7 @@
+ $ref->{libpath} = join '/', (get_config_var($ref, "LIBDEST"),
+ 'config')
+ if ($ref->{libpath} eq 'None');
+- return query_options($ref) unless sanity_check($ref);
++ return $ref;
+ }
+
+ sub test_interrogate {
+@@ -171,6 +171,7 @@
+ Extra Libs: $sel->{syslibs}
+ Python Library: $sel->{libpath}/$sel->{libpython}
+ Include Path: $sel->{incpath}
++
+ END
+ # ' stupid vim.
+ }
diff --git a/dev-perl/Inline-Python/metadata.xml b/dev-perl/Inline-Python/metadata.xml
new file mode 100644
index 000000000000..7639860e78fb
--- /dev/null
+++ b/dev-perl/Inline-Python/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Inline-Python</remote-id>
+ <remote-id type="cpan-module">Inline::Python</remote-id>
+ <remote-id type="cpan-module">Inline::Python::Boolean</remote-id>
+ <remote-id type="cpan-module">Inline::Python::Function</remote-id>
+ <remote-id type="cpan-module">Inline::Python::Object</remote-id>
+ <remote-id type="cpan-module">Inline::Python::Object::Data</remote-id>
+ </upstream>
+</pkgmetadata>