summaryrefslogtreecommitdiff
path: root/dev-perl/Hook-LexWrap/Hook-LexWrap-0.260.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Hook-LexWrap/Hook-LexWrap-0.260.0.ebuild')
-rw-r--r--dev-perl/Hook-LexWrap/Hook-LexWrap-0.260.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Hook-LexWrap/Hook-LexWrap-0.260.0.ebuild b/dev-perl/Hook-LexWrap/Hook-LexWrap-0.260.0.ebuild
new file mode 100644
index 000000000000..80c4d74bcd72
--- /dev/null
+++ b/dev-perl/Hook-LexWrap/Hook-LexWrap-0.260.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.26
+DIST_EXAMPLES=("demo/*")
+inherit perl-module
+
+DESCRIPTION="Lexically scoped subroutine wrappers"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/pod.t
+ perl-module_src_test
+}