summaryrefslogtreecommitdiff
path: root/dev-perl/HTTP-CookieJar/HTTP-CookieJar-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/HTTP-CookieJar/HTTP-CookieJar-0.10.0.ebuild')
-rw-r--r--dev-perl/HTTP-CookieJar/HTTP-CookieJar-0.10.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/HTTP-CookieJar/HTTP-CookieJar-0.10.0.ebuild b/dev-perl/HTTP-CookieJar/HTTP-CookieJar-0.10.0.ebuild
new file mode 100644
index 000000000000..99be876a9552
--- /dev/null
+++ b/dev-perl/HTTP-CookieJar/HTTP-CookieJar-0.10.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=0.010
+inherit perl-module
+
+DESCRIPTION="A minimalist HTTP user agent cookie jar"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? ( dev-perl/Mozilla-PublicSuffix )
+ virtual/perl-Carp
+ dev-perl/HTTP-Date
+ >=virtual/perl-Time-Local-1.190.100
+ virtual/perl-parent
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ !minimal? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ dev-perl/HTTP-Message
+
+ )
+ virtual/perl-File-Spec
+ dev-perl/Test-Deep
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/URI
+ )
+"
+
+# https://github.com/dagolden/HTTP-CookieJar/issues/11
+PERL_RM_FILES=( t/examples.t )