summaryrefslogtreecommitdiff
path: root/dev-perl/Gtk2-Ex-Simple-List/Gtk2-Ex-Simple-List-0.500.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Gtk2-Ex-Simple-List/Gtk2-Ex-Simple-List-0.500.0-r3.ebuild')
-rw-r--r--dev-perl/Gtk2-Ex-Simple-List/Gtk2-Ex-Simple-List-0.500.0-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Gtk2-Ex-Simple-List/Gtk2-Ex-Simple-List-0.500.0-r3.ebuild b/dev-perl/Gtk2-Ex-Simple-List/Gtk2-Ex-Simple-List-0.500.0-r3.ebuild
new file mode 100644
index 000000000000..e2c539d50239
--- /dev/null
+++ b/dev-perl/Gtk2-Ex-Simple-List/Gtk2-Ex-Simple-List-0.500.0-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RMCFARLA
+DIST_VERSION=0.50
+DIST_SECTION=Gtk2-Perl-Ex
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module virtualx
+
+DESCRIPTION="A simple interface to Gtk2's complex MVC list widget"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )" # LGPL-2.1+
+SLOT="0"
+KEYWORDS="amd64 ~ia64 sparc x86"
+
+RDEPEND="
+ >=dev-perl/Gtk2-1.60.0
+ >=dev-perl/glib-perl-1.62.0
+"
+BDEPEND="${RDEPEND}
+"
+
+src_test() {
+ virtx perl-module_src_test
+}