summaryrefslogtreecommitdiff
path: root/dev-perl/Format-Human-Bytes
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Format-Human-Bytes')
-rw-r--r--dev-perl/Format-Human-Bytes/Format-Human-Bytes-0.60.0-r2.ebuild25
-rw-r--r--dev-perl/Format-Human-Bytes/Manifest2
-rw-r--r--dev-perl/Format-Human-Bytes/files/Format-Human-Bytes-0.06-no-dot-inc.patch21
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/Format-Human-Bytes/Format-Human-Bytes-0.60.0-r2.ebuild b/dev-perl/Format-Human-Bytes/Format-Human-Bytes-0.60.0-r2.ebuild
new file mode 100644
index 000000000000..7398d917c3d6
--- /dev/null
+++ b/dev-perl/Format-Human-Bytes/Format-Human-Bytes-0.60.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SEWI
+DIST_VERSION=0.06
+inherit perl-module
+
+DESCRIPTION="Format a bytecount and make it human readable"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.06-no-dot-inc.patch"
+)
diff --git a/dev-perl/Format-Human-Bytes/Manifest b/dev-perl/Format-Human-Bytes/Manifest
index e515b638d69f..e42947fcec1f 100644
--- a/dev-perl/Format-Human-Bytes/Manifest
+++ b/dev-perl/Format-Human-Bytes/Manifest
@@ -1,3 +1,5 @@
+AUX Format-Human-Bytes-0.06-no-dot-inc.patch 455 BLAKE2B 5554f464ba81c6be0fef57444d119d9e4461329692bd607e51dea9f47b59b2e57293768f878b84f5c0290126e370fe52a159ba6b54e007602b1290026f20b8af SHA512 253940b962c24948cda77e75c802fea9ff3728f4270ed1ff4740653c38fae3684e72154c5745947deb8e034c177810a9a51a86c6a74c2950e4484853dd5c8b3d
DIST Format-Human-Bytes-0.06.tar.gz 27183 BLAKE2B d94f83676ce314c2c03530c8b71eb5225467595c01a01d7f1e41cce6dbc904b5ae0c3dc0bbbaf2f82b2511b2122ce676f57e2ff6f69f0106c2209a54fdb65e58 SHA512 a1a1d9fee7ed2382c73939ce073e5cbd53595260076ec8b885219cce99731ca21ea273c9efe11ec66dbabf3133867800e34bdf9d96b4ed2dcecb77cffee704bc
EBUILD Format-Human-Bytes-0.60.0-r1.ebuild 484 BLAKE2B 3b926ab88b57bf94de4704035372997359be65e05d61565c9775d52b93483708c10203f75b466cdf13d1908b1b0e0546a608eaa235937d8ba7f656e869c32307 SHA512 22cd21296094b59296e38bcdef21794d2d5738e2ae574ae7f0f91d53290327c4993280a903764d5eac6e1de860b8903a409121c4bb77ef337416ab550d742872
+EBUILD Format-Human-Bytes-0.60.0-r2.ebuild 451 BLAKE2B f5f4833507c07d31c0bb30638f0b3e91b50a77d85619cea5c1b20842ae0638635fdfb7339fd393ebbc0a2c2e018a2b53db4973700029581a56dc1a88f60edfc0 SHA512 5e1b3d310bd77636cd4aa1a344c6bd86201b4f82f78af3e2d8b0c0ed93dbb6acfe9dc8fe7fc8f20ccca8dcf8d5b545e8ba8eba8b460b484e9cd0abeaf3d64636
MISC metadata.xml 409 BLAKE2B 3bfbc27dff9a1d91496930ded88b542f91b5c171d5f6d4b310bc1c09c0bdada4c4f84b4e48d0558f39a5ba0c35f0f8801b4773c39cc0f5ea2b889c96455a2967 SHA512 49c08325fa586eb91098b9c63ea1dbf2987cd65b6f6fddf622d616e4be1bdc7fcdd076115341157fcee6f877d98ea6957e02e8b2e9e4363e0749ff0ea54fadb5
diff --git a/dev-perl/Format-Human-Bytes/files/Format-Human-Bytes-0.06-no-dot-inc.patch b/dev-perl/Format-Human-Bytes/files/Format-Human-Bytes-0.06-no-dot-inc.patch
new file mode 100644
index 000000000000..af43083966c3
--- /dev/null
+++ b/dev-perl/Format-Human-Bytes/files/Format-Human-Bytes-0.06-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From a1a1935d7951e5baa890dc1150d3112ed79860ba Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 18 Sep 2020 01:32:16 +1200
+Subject: Ensure '.' in @INC on Perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index ee699b3..b5fad9c 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+
+ name 'Format-Human-Bytes';
+--
+2.28.0
+