summaryrefslogtreecommitdiff
path: root/dev-perl/Finance-Quote/Finance-Quote-1.370.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Finance-Quote/Finance-Quote-1.370.0.ebuild')
-rw-r--r--dev-perl/Finance-Quote/Finance-Quote-1.370.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-perl/Finance-Quote/Finance-Quote-1.370.0.ebuild b/dev-perl/Finance-Quote/Finance-Quote-1.370.0.ebuild
new file mode 100644
index 000000000000..68b57c002e74
--- /dev/null
+++ b/dev-perl/Finance-Quote/Finance-Quote-1.370.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=ECOCODE
+MODULE_VERSION=1.37
+inherit perl-module
+
+DESCRIPTION="Get stock and mutual fund quotes from various exchanges"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ~ppc64 x86"
+IUSE="test"
+
+# virtual/perl-Data-Dumper currently commented out in the code
+
+RDEPEND="
+ dev-perl/CGI
+ virtual/perl-Carp
+ dev-perl/DateTime
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ dev-perl/HTML-Parser
+ dev-perl/HTML-TableExtract
+ dev-perl/HTML-Tree
+ dev-perl/HTTP-Cookies
+ dev-perl/HTTP-Message
+ dev-perl/JSON
+ dev-perl/LWP-Protocol-https
+ dev-perl/libwww-perl
+ dev-perl/Mozilla-CA
+ virtual/perl-Time-Piece
+ dev-perl/URI
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ )
+"
+
+SRC_TEST="do parallel"
+
+src_test() {
+ perl_rm_files t/01-pod.t t/02-pod-coverage.t t/03-kwalitee.t \
+ t/04-critic.t t/release-pod-syntax.t
+ perl-module_src_test
+}