summaryrefslogtreecommitdiff
path: root/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild')
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild b/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild
new file mode 100644
index 000000000000..5f498bb091aa
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.39
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST="do parallel"