summaryrefslogtreecommitdiff
path: root/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.340.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.340.0.ebuild')
-rw-r--r--dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.340.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.340.0.ebuild b/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.340.0.ebuild
new file mode 100644
index 000000000000..9f0ef2c25864
--- /dev/null
+++ b/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.340.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=THINC
+DIST_VERSION=0.34
+DIST_EXAMPLES=( "example/*" )
+inherit perl-module
+
+DESCRIPTION="Flexibly parse strings and turn them into DateTime objects"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/DateTime
+ >=dev-perl/DateTime-Format-Builder-0.740.0
+ dev-perl/DateTime-TimeZone
+ dev-perl/List-MoreUtils
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-MockTime
+ dev-perl/Test-NoWarnings
+ >=virtual/perl-Test-Simple-0.440.0
+ )
+"
+
+PERL_RM_FILES=(
+ t/002_pod.t
+ t/003_podcoverage.t
+)