summaryrefslogtreecommitdiff
path: root/dev-perl/DBIx-Migration/DBIx-Migration-0.70.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/DBIx-Migration/DBIx-Migration-0.70.0.ebuild')
-rw-r--r--dev-perl/DBIx-Migration/DBIx-Migration-0.70.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/DBIx-Migration/DBIx-Migration-0.70.0.ebuild b/dev-perl/DBIx-Migration/DBIx-Migration-0.70.0.ebuild
new file mode 100644
index 000000000000..be3fe153f178
--- /dev/null
+++ b/dev-perl/DBIx-Migration/DBIx-Migration-0.70.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=DANIEL
+MODULE_VERSION=0.07
+inherit perl-module
+
+DESCRIPTION="Seamless DB schema up- and downgrades"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/File-Slurp
+ virtual/perl-File-Spec
+ dev-perl/DBI
+ dev-perl/Class-Accessor"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ dev-perl/DBD-SQLite
+ )"
+
+SRC_TEST=do
+
+src_prepare() {
+ use test && perl_rm_files t/02pod.t t/03podcoverage.t
+ perl-module_src_prepare
+}