summaryrefslogtreecommitdiff
path: root/dev-perl/Class-Data-Inheritable/Class-Data-Inheritable-0.80.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Class-Data-Inheritable/Class-Data-Inheritable-0.80.0-r2.ebuild')
-rw-r--r--dev-perl/Class-Data-Inheritable/Class-Data-Inheritable-0.80.0-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-perl/Class-Data-Inheritable/Class-Data-Inheritable-0.80.0-r2.ebuild b/dev-perl/Class-Data-Inheritable/Class-Data-Inheritable-0.80.0-r2.ebuild
new file mode 100644
index 000000000000..445f47db0c68
--- /dev/null
+++ b/dev-perl/Class-Data-Inheritable/Class-Data-Inheritable-0.80.0-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TMTM
+DIST_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION="Inheritable, overridable class data"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+export OPTIMIZE="${CFLAGS}"
+
+src_test() {
+ perl_rm_files t/pod{,-coverage}.t
+ perl-module_src_test
+}