summaryrefslogtreecommitdiff
path: root/dev-perl/Class-C3-Componentised
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Class-C3-Componentised')
-rw-r--r--dev-perl/Class-C3-Componentised/Class-C3-Componentised-1.1.0-r1.ebuild35
-rw-r--r--dev-perl/Class-C3-Componentised/Manifest3
-rw-r--r--dev-perl/Class-C3-Componentised/metadata.xml13
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/Class-C3-Componentised/Class-C3-Componentised-1.1.0-r1.ebuild b/dev-perl/Class-C3-Componentised/Class-C3-Componentised-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..f995f4416714
--- /dev/null
+++ b/dev-perl/Class-C3-Componentised/Class-C3-Componentised-1.1.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=FREW
+MODULE_VERSION=1.001000
+inherit perl-module
+
+DESCRIPTION="Load mix-ins or components to your C3-based class"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~x86-solaris"
+IUSE="test"
+
+RDEPEND="dev-perl/MRO-Compat
+ dev-perl/Class-Inspector
+ >=dev-perl/Class-C3-0.20"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Exception
+ )"
+
+SRC_TEST=do
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install /use lib q[.];\nuse inc::Module::Install /' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
+
+src_test() {
+ perl_rm_files t/pod.t t/pod-coverage.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Class-C3-Componentised/Manifest b/dev-perl/Class-C3-Componentised/Manifest
new file mode 100644
index 000000000000..f79802e9be35
--- /dev/null
+++ b/dev-perl/Class-C3-Componentised/Manifest
@@ -0,0 +1,3 @@
+DIST Class-C3-Componentised-1.001000.tar.gz 24335 BLAKE2B e9208a66e60fa57b8e1668c4d5faa4c761b5b56b674c97269d0a7542bc00ffb50ace8bd0ccb279252d92a12acd6415384e3f544fd178c48fef5b9af38fe244ac SHA512 860b7cd09b1add6f252fddc0934e9f542231be90a57cf36afcab55684aca2fdb667777248c3583ad955ce0b76db44297515f56194ed2ec444dd8c801a01b5713
+EBUILD Class-C3-Componentised-1.1.0-r1.ebuild 737 BLAKE2B 24d76aaa9e81ca1118cd325f71c14c6af819d74863e0bfd884ce81103047281fb572376bcbe5f8ca1790a5cc5213883ae0606f7c846687ab7c752767b6ae8e2e SHA512 8b63a67d9122e41564517d11ed8e4fdf3153eca5639219e173f9f6b80ee4b2b1ab7fd7f36071819db735504259769f0fa6c101fbdb321daa62d04e7f7552c864
+MISC metadata.xml 500 BLAKE2B fc2c9d7db8f7c4c3235a37026142d0451530ed874fb415ec01835b7f89beca60b532566428f1e2b0cef011094e778b5668db70485acbdffa5cb3591b19108394 SHA512 64149be689690f540d374dc8844d89e797d67ebc9309b6b769b8d39174c40ab524d432ff3e3e856b2063915db5bd9fb6b26b3673e8730b58415131bd089b62ba
diff --git a/dev-perl/Class-C3-Componentised/metadata.xml b/dev-perl/Class-C3-Componentised/metadata.xml
new file mode 100644
index 000000000000..9cce2b46d8e3
--- /dev/null
+++ b/dev-perl/Class-C3-Componentised/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Class-C3-Componentised</remote-id>
+ <remote-id type="cpan-module">Class::C3::Componentised</remote-id>
+ <remote-id type="cpan-module">Class::C3::Componentised::ApplyHooks</remote-id>
+ </upstream>
+</pkgmetadata>