summaryrefslogtreecommitdiff
path: root/dev-perl/Cairo/Cairo-1.109.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Cairo/Cairo-1.109.0-r1.ebuild')
-rw-r--r--dev-perl/Cairo/Cairo-1.109.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Cairo/Cairo-1.109.0-r1.ebuild b/dev-perl/Cairo/Cairo-1.109.0-r1.ebuild
new file mode 100644
index 000000000000..7f8242531e34
--- /dev/null
+++ b/dev-perl/Cairo/Cairo-1.109.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=1.109
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Perl interface to the cairo library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=x11-libs/cairo-1.0.0
+"
+DEPEND="
+ >=x11-libs/cairo-1.0.0
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.200.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+ test? (
+ dev-perl/Test-Number-Delta
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.107-fatal-exit.patch"
+ "${FILESDIR}/${PN}-1.109.0-c99.patch"
+)