summaryrefslogtreecommitdiff
path: root/dev-perl/CPAN-Meta-Check/CPAN-Meta-Check-0.18.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/CPAN-Meta-Check/CPAN-Meta-Check-0.18.0.ebuild')
-rw-r--r--dev-perl/CPAN-Meta-Check/CPAN-Meta-Check-0.18.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/CPAN-Meta-Check/CPAN-Meta-Check-0.18.0.ebuild b/dev-perl/CPAN-Meta-Check/CPAN-Meta-Check-0.18.0.ebuild
new file mode 100644
index 000000000000..37b2eefb0c3e
--- /dev/null
+++ b/dev-perl/CPAN-Meta-Check/CPAN-Meta-Check-0.18.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=LEONT
+DIST_VERSION=0.018
+inherit perl-module
+
+DESCRIPTION="Verify requirements in a CPAN::Meta object"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=virtual/perl-CPAN-Meta-2.132.830
+ >=virtual/perl-CPAN-Meta-Requirements-2.121.0
+ virtual/perl-Exporter
+ >=virtual/perl-Module-Metadata-1.0.23
+"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"