summaryrefslogtreecommitdiff
path: root/dev-perl/Benchmark-Timer/Benchmark-Timer-0.711.200-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Benchmark-Timer/Benchmark-Timer-0.711.200-r1.ebuild')
-rw-r--r--dev-perl/Benchmark-Timer/Benchmark-Timer-0.711.200-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Benchmark-Timer/Benchmark-Timer-0.711.200-r1.ebuild b/dev-perl/Benchmark-Timer/Benchmark-Timer-0.711.200-r1.ebuild
new file mode 100644
index 000000000000..cb27e10d2f4a
--- /dev/null
+++ b/dev-perl/Benchmark-Timer/Benchmark-Timer-0.711.200-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DCOPPIT
+DIST_VERSION=0.7112
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Perl code benchmarking tool"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/Statistics-TTest
+ virtual/perl-Time-HiRes
+"
+
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? ( virtual/perl-Test-Simple )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.7112-noauthortests.patch"
+ "${FILESDIR}/${PN}-0.7112-relocateexample.patch"
+)
+
+PERL_RM_FILES=(
+ "inc/Module/Install/AutomatedTester.pm"
+ "inc/Module/Install/Bugtracker.pm"
+ "inc/Module/Install/GithubMeta.pm"
+ "inc/Module/Install/PRIVATE/Enable_Verbose_CPAN_Testing.pm"
+ "inc/Module/Install/StandardTests.pm"
+ "inc/URI/Escape.pm"
+ "private-lib/Module/Install/PRIVATE/Enable_Verbose_CPAN_Testing.pm"
+)