summaryrefslogtreecommitdiff
path: root/dev-perl/Authen-SASL-SASLprep/Authen-SASL-SASLprep-1.100.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Authen-SASL-SASLprep/Authen-SASL-SASLprep-1.100.0-r1.ebuild')
-rw-r--r--dev-perl/Authen-SASL-SASLprep/Authen-SASL-SASLprep-1.100.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Authen-SASL-SASLprep/Authen-SASL-SASLprep-1.100.0-r1.ebuild b/dev-perl/Authen-SASL-SASLprep/Authen-SASL-SASLprep-1.100.0-r1.ebuild
new file mode 100644
index 000000000000..765548e7dd5e
--- /dev/null
+++ b/dev-perl/Authen-SASL-SASLprep/Authen-SASL-SASLprep-1.100.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=CFAERBER
+DIST_VERSION=1.100
+inherit perl-module
+
+DESCRIPTION="A Stringprep Profile for User Names and Passwords (RFC 4013)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-perl/Unicode-Stringprep-1
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.420.0
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-NoWarnings
+ )
+"
+
+src_test() {
+ perl_rm_files t/10pod.t t/11pod_cover.t
+ perl-module_src_test
+}