summaryrefslogtreecommitdiff
path: root/dev-ml/zed/zed-3.2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/zed/zed-3.2.2-r1.ebuild')
-rw-r--r--dev-ml/zed/zed-3.2.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/zed/zed-3.2.2-r1.ebuild b/dev-ml/zed/zed-3.2.2-r1.ebuild
new file mode 100644
index 000000000000..8e32cbb4d079
--- /dev/null
+++ b/dev-ml/zed/zed-3.2.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Abstract engine for text edition in OCaml"
+HOMEPAGE="https://github.com/ocaml-community/zed"
+SRC_URI="https://github.com/ocaml-community/zed/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/dune-3
+ dev-ml/react:=
+ dev-ml/result:=
+ dev-ml/uchar:=
+ dev-ml/uucp:=
+ dev-ml/uuseg:=
+ dev-ml/uutf:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? (
+ dev-ml/alcotest
+)"