summaryrefslogtreecommitdiff
path: root/dev-ml/xdg/xdg-3.16.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/xdg/xdg-3.16.0.ebuild')
-rw-r--r--dev-ml/xdg/xdg-3.16.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/xdg/xdg-3.16.0.ebuild b/dev-ml/xdg/xdg-3.16.0.ebuild
new file mode 100644
index 000000000000..9f13561e8a0f
--- /dev/null
+++ b/dev-ml/xdg/xdg-3.16.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="XDG Base Directory Specification"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
+ -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3.12"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune-compile ${PN}
+}