summaryrefslogtreecommitdiff
path: root/dev-ml/utop/utop-2.11.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/utop/utop-2.11.0-r1.ebuild')
-rw-r--r--dev-ml/utop/utop-2.11.0-r1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-ml/utop/utop-2.11.0-r1.ebuild b/dev-ml/utop/utop-2.11.0-r1.ebuild
deleted file mode 100644
index 0acedbdf1fad..000000000000
--- a/dev-ml/utop/utop-2.11.0-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit dune elisp-common
-
-DESCRIPTION="Universal toplevel for OCaml"
-HOMEPAGE="https://github.com/ocaml-community/utop"
-SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="emacs +ocamlopt"
-
-ELISP_DEPEND="
- emacs? (
- >=app-editors/emacs-24:*
- >=app-emacs/tuareg-mode-2.2.0
- )
-"
-DEPEND="
- dev-ml/lambda-term:=
- dev-ml/logs:=
- dev-ml/lwt:=
- dev-ml/react:=
- dev-ml/zed:=
-"
-RDEPEND="
- ${DEPEND}
- ${ELISP_DEPEND}
-"
-BDEPEND="
- dev-ml/cppo
- dev-ml/findlib
- ${ELISP_DEPEND}
-"
-
-SITEFILE="50${PN}-gentoo.el"
-
-src_compile() {
- dune_src_compile
-
- use emacs &&
- BYTECOMPFLAGS="-L src/top" elisp-compile src/top/*.el
-}
-
-src_install() {
- dune_src_install
-
- if use emacs ; then
- elisp-install ${PN} src/top/*.el{,c}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}