summaryrefslogtreecommitdiff
path: root/dev-ml/reactiveData
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/reactiveData')
-rw-r--r--dev-ml/reactiveData/Manifest4
-rw-r--r--dev-ml/reactiveData/metadata.xml11
-rw-r--r--dev-ml/reactiveData/reactiveData-0.2.1.ebuild36
-rw-r--r--dev-ml/reactiveData/reactiveData-9999.ebuild36
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-ml/reactiveData/Manifest b/dev-ml/reactiveData/Manifest
new file mode 100644
index 000000000000..5b9a2f3661bb
--- /dev/null
+++ b/dev-ml/reactiveData/Manifest
@@ -0,0 +1,4 @@
+DIST reactiveData-0.2.1.tar.gz 21219 BLAKE2B f3b1c4a4007fc3aefbc34d64ba5ffba5216aee675796719fde11c3c970a431cffbd6dccb35c8cc0192fcc68c7f80f06da91b1000d50ee9f3116efd6febc7e242 SHA512 e4dad870fd1f669566394d9c2ab52665a3d27f6b2dd3807dba245d89ca90eda08b98b266fb0795bcfa5cb4ffed7a86aa719f8db5c316b0d920ee3c342493d029
+EBUILD reactiveData-0.2.1.ebuild 815 BLAKE2B 25667840e8c953db8677a9a57d244b568cee148d24cb873142f28515f24c7c6160b2751733d6b723dc0c2ae3d0a97d87798a4f547755d7b02816c937796c03ad SHA512 d634e3f1c4beeed29a6664c546e6e44746fb6225a2855a753374484e57c1d3e031dd49e306b6f5400999abef45bf4346123f4aa5adfada3b43e1c73103908323
+EBUILD reactiveData-9999.ebuild 815 BLAKE2B 25667840e8c953db8677a9a57d244b568cee148d24cb873142f28515f24c7c6160b2751733d6b723dc0c2ae3d0a97d87798a4f547755d7b02816c937796c03ad SHA512 d634e3f1c4beeed29a6664c546e6e44746fb6225a2855a753374484e57c1d3e031dd49e306b6f5400999abef45bf4346123f4aa5adfada3b43e1c73103908323
+MISC metadata.xml 332 BLAKE2B 923287ded25c6a31f1e0daa4e2802ebbda3f2c2032eb10068e2c35774c1fc832b70625de1249df4a54ebe3a4f16c49d40c8f8a777cdc1d3b12b51ee4ffc15428 SHA512 860178f9dd8a157f3b9ac3e5ae70cf703913ad7644051d688928e2c9466b89256c4f145942ea6f4f8faf411547c49cecca7a2e624f2b578d68b6330197c87831
diff --git a/dev-ml/reactiveData/metadata.xml b/dev-ml/reactiveData/metadata.xml
new file mode 100644
index 000000000000..ab53110f16be
--- /dev/null
+++ b/dev-ml/reactiveData/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocsigen/reactiveData</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/reactiveData/reactiveData-0.2.1.ebuild b/dev-ml/reactiveData/reactiveData-0.2.1.ebuild
new file mode 100644
index 000000000000..a74fc715fcf0
--- /dev/null
+++ b/dev-ml/reactiveData/reactiveData-0.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit opam
+
+DESCRIPTION="Functional reactive programming with incremental changes in data structures"
+HOMEPAGE="https://github.com/ocsigen/reactiveData"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/reactiveData"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/reactiveData/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-ml/react:="
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+}
diff --git a/dev-ml/reactiveData/reactiveData-9999.ebuild b/dev-ml/reactiveData/reactiveData-9999.ebuild
new file mode 100644
index 000000000000..a74fc715fcf0
--- /dev/null
+++ b/dev-ml/reactiveData/reactiveData-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit opam
+
+DESCRIPTION="Functional reactive programming with incremental changes in data structures"
+HOMEPAGE="https://github.com/ocsigen/reactiveData"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/reactiveData"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/reactiveData/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-ml/react:="
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+}