summaryrefslogtreecommitdiff
path: root/dev-ml/qcheck/qcheck-0.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/qcheck/qcheck-0.18.ebuild')
-rw-r--r--dev-ml/qcheck/qcheck-0.18.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/qcheck/qcheck-0.18.ebuild b/dev-ml/qcheck/qcheck-0.18.ebuild
new file mode 100644
index 000000000000..5732be261e72
--- /dev/null
+++ b/dev-ml/qcheck/qcheck-0.18.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="QuickCheck inspired property-based testing for OCaml"
+HOMEPAGE="https://github.com/c-cube/qcheck"
+SRC_URI="https://github.com/c-cube/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" # tests fail
+
+RDEPEND="
+ dev-ml/alcotest:=
+ dev-ml/ounit2:=
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ # "ppx_deriving_qcheck" does not install but only "ppx_pbt" depends on it
+ local i
+ for i in qcheck qcheck-alcotest qcheck-core qcheck-ounit ; do
+ dune_src_install ${i}
+ done
+
+ einstalldocs
+}
+
+src_test() {
+ emake test
+}