summaryrefslogtreecommitdiff
path: root/dev-ml/protocol_version_header/protocol_version_header-0.16.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/protocol_version_header/protocol_version_header-0.16.0.ebuild')
-rw-r--r--dev-ml/protocol_version_header/protocol_version_header-0.16.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/protocol_version_header/protocol_version_header-0.16.0.ebuild b/dev-ml/protocol_version_header/protocol_version_header-0.16.0.ebuild
new file mode 100644
index 000000000000..abfa5a73185b
--- /dev/null
+++ b/dev-ml/protocol_version_header/protocol_version_header-0.16.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Protocol aware version negotiation for OCaml"
+HOMEPAGE="https://github.com/janestreet/protocol_version_header"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/core:${SLOT}
+ dev-ml/ppx_jane:${SLOT}
+"
+DEPEND="${RDEPEND}"