summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_sexp_message/ppx_sexp_message-0.15.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_sexp_message/ppx_sexp_message-0.15.0.ebuild')
-rw-r--r--dev-ml/ppx_sexp_message/ppx_sexp_message-0.15.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_message/ppx_sexp_message-0.15.0.ebuild b/dev-ml/ppx_sexp_message/ppx_sexp_message-0.15.0.ebuild
new file mode 100644
index 000000000000..a935e8a92243
--- /dev/null
+++ b/dev-ml/ppx_sexp_message/ppx_sexp_message-0.15.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A ppx rewriter for easy construction of s-expressions"
+HOMEPAGE="https://github.com/janestreet/ppx_sexp_message"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/ppx_here:${SLOT}
+ dev-ml/ppx_sexp_conv:${SLOT}
+"
+RDEPEND="${DEPEND}"