summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2-r2.ebuild')
-rw-r--r--dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2-r2.ebuild b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2-r2.ebuild
new file mode 100644
index 000000000000..017dfbd5279f
--- /dev/null
+++ b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Support Library for type-driven code generators"
+HOMEPAGE="https://github.com/janestreet/ppx_sexp_conv"
+SRC_URI="https://github.com/janestreet/ppx_sexp_conv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 x86"
+IUSE="+ocamlopt"
+
+# Upper bound on ppxlib for bug #769536
+DEPEND="
+ =dev-ml/base-0.14*:=[ocamlopt?]
+ dev-ml/findlib:=[ocamlopt?]
+ <dev-ml/ppxlib-0.21.0:=[ocamlopt?]
+ dev-ml/ocaml-compiler-libs:=[ocamlopt?]
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=[ocamlopt?]
+ dev-ml/cinaps:=[ocamlopt?]
+ dev-ml/sexplib0:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"