summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_module_timer/ppx_module_timer-0.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_module_timer/ppx_module_timer-0.14.0.ebuild')
-rw-r--r--dev-ml/ppx_module_timer/ppx_module_timer-0.14.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/ppx_module_timer/ppx_module_timer-0.14.0.ebuild b/dev-ml/ppx_module_timer/ppx_module_timer-0.14.0.ebuild
new file mode 100644
index 000000000000..c4ce24c4a2ff
--- /dev/null
+++ b/dev-ml/ppx_module_timer/ppx_module_timer-0.14.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Ppx rewriter that records top-level module startup times"
+HOMEPAGE="https://github.com/janestreet/ppx_module_timer"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ >=dev-ml/ppx_base-0.14.0:=
+ >=dev-ml/stdio-0.14.0:=
+ >=dev-ml/time_now-0.14.0:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+"
+RDEPEND="${DEPEND}"