summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_deriving/ppx_deriving-5.2.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_deriving/ppx_deriving-5.2.1-r1.ebuild')
-rw-r--r--dev-ml/ppx_deriving/ppx_deriving-5.2.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving/ppx_deriving-5.2.1-r1.ebuild b/dev-ml/ppx_deriving/ppx_deriving-5.2.1-r1.ebuild
new file mode 100644
index 000000000000..a62e03fa377d
--- /dev/null
+++ b/dev-ml/ppx_deriving/ppx_deriving-5.2.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Type-driven code generation for OCaml"
+HOMEPAGE="https://github.com/ocaml-ppx/ppx_deriving"
+SRC_URI="https://github.com/ocaml-ppx/ppx_deriving/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/ppx_tools:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_derivers:=
+ >=dev-ml/ppxlib-0.20.0:=
+ dev-ml/findlib:=
+ dev-ml/result:=
+ dev-ml/sexplib0:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+ test? ( dev-ml/ounit2 )"