summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_compare/ppx_compare-0.17.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_compare/ppx_compare-0.17.0.ebuild')
-rw-r--r--dev-ml/ppx_compare/ppx_compare-0.17.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/ppx_compare/ppx_compare-0.17.0.ebuild b/dev-ml/ppx_compare/ppx_compare-0.17.0.ebuild
new file mode 100644
index 000000000000..ba30c76d734f
--- /dev/null
+++ b/dev-ml/ppx_compare/ppx_compare-0.17.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Generation of comparison functions from types"
+HOMEPAGE="https://github.com/janestreet/ppx_compare"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base:${SLOT}[ocamlopt?]
+ >=dev-ml/ppxlib-0.32.1:=[ocamlopt?]
+ dev-ml/ppxlib_jane:${SLOT}[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"