summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_base/ppx_base-0.17.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_base/ppx_base-0.17.0.ebuild')
-rw-r--r--dev-ml/ppx_base/ppx_base-0.17.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ppx_base/ppx_base-0.17.0.ebuild b/dev-ml/ppx_base/ppx_base-0.17.0.ebuild
new file mode 100644
index 000000000000..3f2a1d39c92c
--- /dev/null
+++ b/dev-ml/ppx_base/ppx_base-0.17.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Base set of ppx rewriters"
+HOMEPAGE="https://github.com/janestreet/ppx_base"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/ppx_cold:${SLOT}[ocamlopt?]
+ dev-ml/ppx_compare:${SLOT}[ocamlopt?]
+ dev-ml/ppx_enumerate:${SLOT}[ocamlopt?]
+ dev-ml/ppx_globalize:${SLOT}[ocamlopt?]
+ dev-ml/ppx_hash:${SLOT}[ocamlopt?]
+ dev-ml/ppx_sexp_conv:${SLOT}[ocamlopt?]
+ >=dev-ml/ppxlib-0.32.1:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"