summaryrefslogtreecommitdiff
path: root/dev-ml/opam-installer/opam-installer-2.1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/opam-installer/opam-installer-2.1.6.ebuild')
-rw-r--r--dev-ml/opam-installer/opam-installer-2.1.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/opam-installer-2.1.6.ebuild b/dev-ml/opam-installer/opam-installer-2.1.6.ebuild
new file mode 100644
index 000000000000..c8d56c6f4111
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.1.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+inherit dune
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+S="${WORKDIR}/opam-full-${PV/_/-}"
+OPAM_INSTALLER="${S}/_build/install/default/bin/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" # sandbox not working
+
+RDEPEND="
+ dev-ml/cmdliner:=[ocamlopt?]
+ ~dev-ml/opam-${PV}:=[ocamlopt?]
+ dev-ml/dose3:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}
+
+src_compile() {
+ dune-compile ${PN}
+}