summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-websocket
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-websocket')
-rw-r--r--dev-ml/ocaml-websocket/Manifest3
-rw-r--r--dev-ml/ocaml-websocket/metadata.xml12
-rw-r--r--dev-ml/ocaml-websocket/ocaml-websocket-2.9.ebuild51
3 files changed, 0 insertions, 66 deletions
diff --git a/dev-ml/ocaml-websocket/Manifest b/dev-ml/ocaml-websocket/Manifest
deleted file mode 100644
index a241d80003f3..000000000000
--- a/dev-ml/ocaml-websocket/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST ocaml-websocket-2.9.tar.gz 23946 BLAKE2B adea61c5b163c995f3fcdc9789ef718bbfc5b22f3ef755795d54d0ba7357797fd5c358da88a7fbc5986c728b2705d5f34c7f3d4c8f2c2a9aa857a4b6add98b5f SHA512 eab5e4f971985c03ca70b46abb54ca8a09491e5ebc803b57ddf8447447b6926da2117fd882c7cb5a9a7282290e756f535e4584f09cbd21ce2554f20df1db7ae8
-EBUILD ocaml-websocket-2.9.ebuild 1212 BLAKE2B 51e836414bd01bdc5f2bb3494096527aa70c54e83138469dcaa90ebc16d66a85ca096711170fd2da5ea107f434779619d8e7cffc4c3884ff1c29c7ab9bbce359 SHA512 8c35ce20d678495f29c541f08de7295f60d3560a1e6be9a677f11758b1912204b68bc31273823c9a8f82efc24cb53562b06a9ae89e68d5ddb11474030e18d847
-MISC metadata.xml 491 BLAKE2B f587bf59bca6df692affbfd0123bc0fb9aa3235db6cf865e58d98b6662bfd31196b881e1f693f1de7fbb7db88e41ecc80f60a9d283716326d4c9953792a64942 SHA512 1df916156f61947aa8e5d678188710887cae169374e3dafa004ac9b0950dc2c0e68b405fc893601dfe556efc05a60c3c32fdfb9b948ebd413a4d29cb1666f75c
diff --git a/dev-ml/ocaml-websocket/metadata.xml b/dev-ml/ocaml-websocket/metadata.xml
deleted file mode 100644
index b1b38f7baa49..000000000000
--- a/dev-ml/ocaml-websocket/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="async">Enables support for the <pkg>dev-ml/async</pkg> asynchronous execution library.</flag>
- <flag name="lwt">Enables support for the <pkg>dev-ml/lwt</pkg> cooperative light-weight thread library.</flag>
- </use>
- <upstream>
- <remote-id type="github">vbmithr/ocaml-websocket</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ml/ocaml-websocket/ocaml-websocket-2.9.ebuild b/dev-ml/ocaml-websocket/ocaml-websocket-2.9.ebuild
deleted file mode 100644
index 359784d9c447..000000000000
--- a/dev-ml/ocaml-websocket/ocaml-websocket-2.9.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit opam
-
-DESCRIPTION="Websocket library for OCaml"
-HOMEPAGE="https://github.com/vbmithr/ocaml-websocket"
-SRC_URI="https://github.com/vbmithr/ocaml-websocket/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="+ocamlopt async +ssl lwt"
-
-DEPEND="
- dev-lang/ocaml:=[ocamlopt?]
- dev-ml/astring:=[ocamlopt(+)?]
- dev-ml/ocaml-cohttp:=[ocamlopt(+)?,async?,lwt?]
- dev-ml/cppo:=[ocamlopt(+)?]
- dev-ml/ocplib-endian:=[ocamlopt(+)?]
- async? (
- dev-ml/async:=[ocamlopt(+)?]
- ssl? ( dev-ml/async_ssl:=[ocamlopt(+)?] )
- )
- lwt? ( dev-ml/lwt:=[ocamlopt(+)?] )
- ssl? ( dev-ml/cryptokit:=[ocamlopt(+)?] )
-
-"
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND}
- dev-ml/ocamlbuild"
-
-src_compile() {
- ocaml pkg/build.ml \
- native=$(usex ocamlopt true false) \
- native-dynlink=$(usex ocamlopt true false) \
- lwt=$(usex lwt true false) \
- async=$(usex async true false) \
- async_ssl=$(usex async "$(usex ssl true false)" false) \
- nocrypto=false \
- cryptokit=$(usex ssl true false) \
- test=false \
- || die
-}
-
-src_install() {
- opam_src_install websocket
- dodoc README CHANGES
-}