summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-sha/ocaml-sha-1.15.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-sha/ocaml-sha-1.15.2.ebuild')
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.15.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.15.2.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.15.2.ebuild
new file mode 100644
index 000000000000..dca25b58d530
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.15.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=sha
+
+inherit dune
+
+DESCRIPTION="Binding to the SHA cryptographic functions"
+HOMEPAGE="https://github.com/djs55/ocaml-sha/"
+SRC_URI="https://github.com/djs55/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-ml/stdlib-shims:="
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"