summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild')
-rw-r--r--dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild b/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild
new file mode 100644
index 000000000000..66969b86741b
--- /dev/null
+++ b/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Easy process control for OCaml"
+HOMEPAGE="https://github.com/dsheets/ocaml-process"
+SRC_URI="https://github.com/dsheets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-ml/ocamlbuild
+ test? ( dev-ml/alcotest )
+"
+
+src_install() {
+ findlib_src_install
+}
+
+src_test() {
+ emake -j1 test
+}