summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild')
-rw-r--r--dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild b/dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild
new file mode 100644
index 000000000000..17c16d0e2fa3
--- /dev/null
+++ b/dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Convert file extensions to MIME types"
+HOMEPAGE="https://github.com/mirage/ocaml-magic-mime"
+SRC_URI="https://github.com/mirage/ocaml-magic-mime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/ocaml:="
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ magic-mime.install || die
+}