summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-hashcons/ocaml-hashcons-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-hashcons/ocaml-hashcons-1.2.ebuild')
-rw-r--r--dev-ml/ocaml-hashcons/ocaml-hashcons-1.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-hashcons/ocaml-hashcons-1.2.ebuild b/dev-ml/ocaml-hashcons/ocaml-hashcons-1.2.ebuild
new file mode 100644
index 000000000000..e2f3672faae6
--- /dev/null
+++ b/dev-ml/ocaml-hashcons/ocaml-hashcons-1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools findlib
+
+DESCRIPTION="OCaml hash-consing library"
+HOMEPAGE="https://github.com/backtracking/ocaml-hashcons"
+SRC_URI="https://github.com/backtracking/ocaml-hashcons/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+ sed -i -e 's/$(OCAMLFIND) remove/#/' Makefile.in || die
+}
+
+src_compile() {
+ if use ocamlopt; then
+ emake opt byte
+ else
+ emake byte
+ fi
+}
+
+src_install() {
+ dodir "$(ocamlfind printconf destdir)/hashcons"
+ emake DESTDIR="-destdir ${D}/$(ocamlfind printconf destdir)/" $(usex ocamlopt install-opt install-byte)
+ dodoc README.md CHANGES
+}