summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild')
-rw-r--r--dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild
new file mode 100644
index 000000000000..72c2b68e4139
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="fileutils"
+
+inherit dune
+
+DESCRIPTION="Pure OCaml functions to manipulate real file (POSIX like) and filename"
+HOMEPAGE="https://github.com/gildor478/ocaml-fileutils"
+SRC_URI="https://github.com/gildor478/${PN}/releases/download/v${PV}/${DUNE_PKG_NAME}-v${PV}.tbz -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-ml/ounit2-2.0.0
+ >=dev-ml/stdlib-shims-0.2.0"
+
+DOCS=( "README.md" "CHANGES.md" "LICENSE.txt" )
+
+S="${WORKDIR}/${DUNE_PKG_NAME}-v${PV}"
+
+src_prepare() {
+ default
+
+ # Port to dev-ml/ounit2
+ sed -i -e 's/oUnit/ounit2/' test/dune || die
+}