summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-doc/ocaml-doc-4.04.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-doc/ocaml-doc-4.04.ebuild')
-rw-r--r--dev-ml/ocaml-doc/ocaml-doc-4.04.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/ocaml-doc/ocaml-doc-4.04.ebuild b/dev-ml/ocaml-doc/ocaml-doc-4.04.ebuild
new file mode 100644
index 000000000000..46e0e0b6687c
--- /dev/null
+++ b/dev-ml/ocaml-doc/ocaml-doc-4.04.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Ocaml reference manual (html)"
+HOMEPAGE="http://caml.inria.fr/pub/docs/manual-ocaml/"
+SRC_URI="http://caml.inria.fr/pub/distrib/ocaml-${PV}/ocaml-${PV}-refman-html.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="amd64 ~ppc x86"
+
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/htmlman
+
+src_install() {
+ dohtml -r *
+}
+
+pkg_postinst() {
+ elog "This manual is available online at http://caml.inria.fr/pub/docs/manual-ocaml/"
+}