summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild')
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild
new file mode 100644
index 000000000000..fbec82b5da87
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=ctypes
+inherit dune
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/yallop/ocaml-ctypes/"
+SRC_URI="https://github.com/yallop/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.03:=
+ >=dev-libs/libffi-3.3_rc0:=
+ dev-ml/bigarray-compat:=
+ dev-ml/integers:=
+ dev-ml/dune-configurator:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 dev-ml/lwt )"
+REQUIRED_USE="ocamlopt"
+
+src_install() {
+ dune-install ctypes ctypes-foreign
+}