summaryrefslogtreecommitdiff
path: root/dev-ml/menhir/menhir-20190924.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/menhir/menhir-20190924.ebuild')
-rw-r--r--dev-ml/menhir/menhir-20190924.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-ml/menhir/menhir-20190924.ebuild b/dev-ml/menhir/menhir-20190924.ebuild
deleted file mode 100644
index 495e751288a2..000000000000
--- a/dev-ml/menhir/menhir-20190924.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit findlib
-
-DESCRIPTION="LR(1) parser generator for the OCaml language"
-HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
-SRC_URI="https://gitlab.inria.fr/fpottier/${PN}/-/archive/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="amd64 arm arm64 ~ppc ppc64 x86"
-IUSE="examples +ocamlopt"
-
-RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]"
-DEPEND="${RDEPEND}
- dev-ml/ocamlbuild"
-
-src_configure() {
- if ! use ocamlopt ; then
- export TARGET=byte
- fi
-}
-
-src_compile() {
- emake PREFIX="${EPREFIX}"/usr -j1
-}
-
-src_install() {
- findlib_src_preinst
-
- emake \
- PREFIX="${ED}"/usr \
- docdir="${ED}"/usr/share/doc/${PF} \
- $(use examples || echo "DOCS=manual.pdf") \
- install
-
- use examples && docompress -x /usr/share/doc/${PF}/demos
- dodoc README.md CHANGES.md
-}