summaryrefslogtreecommitdiff
path: root/dev-ml/markup/markup-1.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/markup/markup-1.0.0-r1.ebuild')
-rw-r--r--dev-ml/markup/markup-1.0.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/markup/markup-1.0.0-r1.ebuild b/dev-ml/markup/markup-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..fdce883345f3
--- /dev/null
+++ b/dev-ml/markup/markup-1.0.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
+HOMEPAGE="https://github.com/aantron/markup.ml"
+SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-ml/lwt:=
+ dev-ml/uutf:="
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 )"
+
+S="${WORKDIR}/${PN}.ml-${PV}"