summaryrefslogtreecommitdiff
path: root/dev-ml/macaque/macaque-0.7.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/macaque/macaque-0.7.4.ebuild')
-rw-r--r--dev-ml/macaque/macaque-0.7.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/macaque/macaque-0.7.4.ebuild b/dev-ml/macaque/macaque-0.7.4.ebuild
new file mode 100644
index 000000000000..f8b8e3fb069d
--- /dev/null
+++ b/dev-ml/macaque/macaque-0.7.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="DSL for SQL Queries in Caml"
+HOMEPAGE="http://ocsigen.org/macaque/"
+SRC_URI="https://github.com/ocsigen/macaque/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/pgocaml-2.1:=
+ dev-ml/camlp4:="
+DEPEND="${RDEPEND}
+ dev-ml/oasis"
+DOCS=( Changelog README.md )
+OASIS_SETUP_COMMAND="./setup.exe"
+
+src_configure() {
+ emake setup.exe
+ oasis_src_configure
+}